TTN AU915 and MLS stack issues

Phil Whitehouse from London, United Kingdom, aka Phillie Casablanca on Flickr, CC BY 2.0 , via Wikimedia Commons

Our EyeBee400L depth sensors, deployed in Australia had a curious issue. It just wasn’t able to receive downlinks (packets from our server to device, usually sent for configuration changes). The same device (copy) was working perfectly fine in IN865 band at our labs

After much hair-pulling and days of remote debug sessions on our partner’s computer in Australia, we figured out that the issue was most probably with the MicrochipⓇ LoRaWANⓇ Stack (MLS) that was embedded in our device firmware. We were using the latest version of the MLS (1.0.5) that was bundled with the Microchip Studio.

In the end, we figured out the issue and understood that we need to downgrade the MLS stack to an older one (MLS 1.0.3). However, we opportunity to completely update our firmware with some new optimizations and FUOTA (Firmware Over The Air) download capability.

While the MLS stack works fine for most cases and there is good documentation for the basic use cases, there is a lack of documentation on some of the advanced features, even with the examples supplied by Microchip Inc. (eg: FUOTA, UART bootloader). If anyone reading this post can share any resources they know of for these topics for the SAMR34/35 devices, please do comment.

You can read more on the issue on the following TTN forum post:

WLR089U0 Unable to receive downlinks in AU915 – End Devices (Nodes) / SAMR34 – The Things Network

By adminBee

#maximizeLife

Leave a comment

Your email address will not be published.